use strict;
my $str = '<img src="image1.png" class="image1">
';
my $regex = qr/src=\"[^\"]+\"/p;
my $subst = 'src="image-replaced.png"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";