// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"src=\"[^\"]+\""#).unwrap();
let string = "<img src=\"image1.png\" class=\"image1\">
";
let substitution = "src=\"image-replaced.png\"";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}