re = /src=\"[^\"]+\"/
str = '<img src="image1.png" class="image1">
'
subst = 'src="image-replaced.png"'
result = str.sub(re, subst)
# Print the result of the substitution
puts result