import Foundation
let pattern = #"src=\"[^\"]+\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img src="image1.png" class="image1">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"src="image-replaced.png""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}