$re = '/src=\"[^\"]+\"/';
$str = '<img src="image1.png" class="image1">
';
$subst = "src=\"image-replaced.png\"";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;