#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "src=\"[^\"]+\""
Local $sString = "<img src="image1.png" class="image1">" & @CRLF & _
""
Local $sSubst = "src="image-replaced.png""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)