# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+/ /g;t' <<< " this is the content with double spaces
this is the second content with double spaces "