$re = '/\s+/';
$str = ' this is the content with double spaces
this is the second content with double spaces ';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;