#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s+"
Local $sString = " this is the content with double spaces " & @CRLF & _
" this is the second content with double spaces "
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)