package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s+`)
var str = ` this is the content with double spaces
this is the second content with double spaces `
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}