use strict;
my $str = ' this is the content with double spaces
this is the second content with double spaces ';
my $regex = qr/\s+/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";