re = /\s+/
str = ' this is the content with double spaces
this is the second content with double spaces '
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result