const regex = /\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+', 'g')
const str = ` this is the content with double spaces
this is the second content with double spaces `;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);