#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]+(?:_[A-Z]+)*$"
Local $sString = "HELLO" & @CRLF & _
"HELLO_WORLD" & @CRLF & _
"HELLO_WORLD_HELLO_WORLD" & @CRLF & _
"HELLO WORLD" & @CRLF & _
"hello_world" & @CRLF & _
"HELLO_WORLD HELLO"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")