use strict;
my $str = 'HELLO
HELLO_WORLD
HELLO_WORLD_HELLO_WORLD
HELLO WORLD
hello_world
HELLO_WORLD HELLO';
my $regex = qr/^[A-Z]+(?:_[A-Z]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}