// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]+(?:_[A-Z]+)*$").unwrap();
let string = "HELLO
HELLO_WORLD
HELLO_WORLD_HELLO_WORLD
HELLO WORLD
hello_world
HELLO_WORLD HELLO";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}