package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]+(?:_[A-Z]+)*$`)
var str = `HELLO
HELLO_WORLD
HELLO_WORLD_HELLO_WORLD
HELLO WORLD
hello_world
HELLO_WORLD HELLO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}