import re
regex = re.compile(r"^[A-Z]+(?:_[A-Z]+)*$", flags=re.MULTILINE)
test_str = ("HELLO\n"
"HELLO_WORLD\n"
"HELLO_WORLD_HELLO_WORLD\n"
"HELLO WORLD\n"
"hello_world\n"
"HELLO_WORLD HELLO")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")