re = /^[A-Z]+(?:_[A-Z]+)*$/m
str = 'HELLO
HELLO_WORLD
HELLO_WORLD_HELLO_WORLD
HELLO WORLD
hello_world
HELLO_WORLD HELLO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end