$re = '/^[A-Z]+(?:_[A-Z]+)*$/m';
$str = 'HELLO
HELLO_WORLD
HELLO_WORLD_HELLO_WORLD
HELLO WORLD
hello_world
HELLO_WORLD HELLO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);