#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:^')?(.')\1*(?:.$)?"
Local $sString = "'a'a'a'a'b'c'c'a'a'd'e'e'e'e"
Local $sSubst = "$0\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)