import re
regex = re.compile(r"(?:^')?(.')\1*(?:.$)?")
test_str = "'a'a'a'a'b'c'c'a'a'd'e'e'e'e"
subst = "$0\\n"
result = regex.sub(subst, test_str)
if result:
print(result)