const regex = /(?:^')?(.')\1*(?:.$)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\')?(.\')\\1*(?:.$)?', 'g')
const str = `'a'a'a'a'b'c'c'a'a'd'e'e'e'e`;
const subst = `$0\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);