$re = '/(?:^\')?(.\')\1*(?:.$)?/';
$str = '\'a\'a\'a\'a\'b\'c\'c\'a\'a\'d\'e\'e\'e\'e';
$subst = "$0\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;