using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^')?(.')\1*(?:.$)?";
string substitution = @"$0\n";
string input = @"'a'a'a'a'b'c'c'a'a'd'e'e'e'e";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}