# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/=(?|(")((?:(?![a-z]*=)[^"<>])*)()(?=[\s>]|\\/>)|(?!")()((?:(?![a-z]*=)[^"<>])*)("))/="$2"/g;t' <<< "<table pgwide=\"0\" id=\"dvr_config_firmware>
<title>DFR Firmware</title>
<tgroup cols=\"2\">
<colspec colname=\"col1>
<colspec colname=\"col2\">
<info date=\"09 JAN 2000 version=\"1.0\">
"