using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=(?|("")((?:(?![a-z]*=)[^""<>])*)()(?=[\s>]|\/>)|(?!"")()((?:(?![a-z]*=)[^""<>])*)(""))";
string substitution = @"=""$2""";
string input = @"<table pgwide=""0"" id=""dvr_config_firmware>
<title>DFR Firmware</title>
<tgroup cols=""2"">
<colspec colname=""col1>
<colspec colname=""col2"">
<info date=""09 JAN 2000 version=""1.0"">
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}