import Foundation
let pattern = #"=(?|(")((?:(?![a-z]*=)[^"<>])*)()(?=[\s>]|\/>)|(?!")()((?:(?![a-z]*=)[^"<>])*)("))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<table pgwide="0" id="dvr_config_firmware>
<title>DFR Firmware</title>
<tgroup cols="2">
<colspec colname="col1>
<colspec colname="col2">
<info date="09 JAN 2000 version="1.0">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"="$2""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)