$re = '/=(?|(")((?:(?![a-z]*=)[^"<>])*)()(?=[\s>]|\/>)|(?!")()((?:(?![a-z]*=)[^"<>])*)("))/';
$str = '<table pgwide="0" id="dvr_config_firmware>
<title>DFR Firmware</title>
<tgroup cols="2">
<colspec colname="col1>
<colspec colname="col2">
<info date="09 JAN 2000 version="1.0">
';
$subst = "=\"$2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;