import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=(?|(\")((?:(?![a-z]*=)[^\"<>])*)()(?=[\\s>]|\\/>)|(?!\")()((?:(?![a-z]*=)[^\"<>])*)(\"))";
final String string = "<table pgwide=\"0\" id=\"dvr_config_firmware>\n"
+ "<title>DFR Firmware</title>\n"
+ "<tgroup cols=\"2\">\n"
+ "<colspec colname=\"col1>\n"
+ "<colspec colname=\"col2\">\n\n"
+ "<info date=\"09 JAN 2000 version=\"1.0\">\n";
final String subst = "=\"$2\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}