# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"=(?|(\")((?:(?![a-z]*=)[^\"<>])*)()(?=[\s>]|\/>)|(?!\")()((?:(?![a-z]*=)[^\"<>])*)(\"))"
test_str = ("<table pgwide=\"0\" id=\"dvr_config_firmware>\n"
"<title>DFR Firmware</title>\n"
"<tgroup cols=\"2\">\n"
"<colspec colname=\"col1>\n"
"<colspec colname=\"col2\">\n\n"
"<info date=\"09 JAN 2000 version=\"1.0\">\n")
subst = "=\"$2\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.