#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$[0-9\s]{1,}"
Local $sString = "$ 1" & @CRLF & _
"$ 300 тест " & @CRLF & _
"тест $ 500 000" & @CRLF & _
"тест $ 6 000 000 тест" & @CRLF & _
"$ 5 539 123 053"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")