using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$[0-9\s]{1,}";
string input = @"$ 1
$ 300 тест
тест $ 500 000
тест $ 6 000 000 тест
$ 5 539 123 053";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}