re = /\$[0-9\s]{1,}/
str = '$ 1
$ 300 тест
тест $ 500 000
тест $ 6 000 000 тест
$ 5 539 123 053'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end