// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$[0-9\s]{1,}").unwrap();
let string = "$ 1
$ 300 тест
тест $ 500 000
тест $ 6 000 000 тест
$ 5 539 123 053";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}