package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$[0-9\s]{1,}`)
var str = `$ 1
$ 300 тест
тест $ 500 000
тест $ 6 000 000 тест
$ 5 539 123 053`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}