$re = '/\$[0-9\s]{1,}/';
$str = '$ 1
$ 300 тест
тест $ 500 000
тест $ 6 000 000 тест
$ 5 539 123 053';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);