import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$[0-9\\s]{1,}";
final String string = "$ 1\n"
+ "$ 300 тест \n"
+ "тест $ 500 000\n"
+ "тест $ 6 000 000 тест\n"
+ "$ 5 539 123 053";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}