using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([{,])(\w+)(\s+)?:";
string substitution = @"$1""$2"":";
string input = @"[{endTime:""2019-06-05T17:15:00.000+10:00"",startTime:""2019-06-05T17:00:00.000+10:00""}]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}