$re = '/([{,])(\w+)(\s+)?:/mi';
$str = '[{endTime:"2019-06-05T17:15:00.000+10:00",startTime:"2019-06-05T17:00:00.000+10:00"}]';
$subst = "$1\"$2\":";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;