package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([{,])(\w+)(\s+)?:`)
var str = `[{endTime:"2019-06-05T17:15:00.000+10:00",startTime:"2019-06-05T17:00:00.000+10:00"}]`
var substitution = "$1"$2":"
fmt.Println(re.ReplaceAllString(str, substitution))
}