import re
regex = re.compile(r"([{,])(\w+)(\s+)?:", flags=re.MULTILINE | re.IGNORECASE)
test_str = "[{endTime:\"2019-06-05T17:15:00.000+10:00\",startTime:\"2019-06-05T17:00:00.000+10:00\"}]"
subst = "$1\"$2\":"
result = regex.sub(subst, test_str)
if result:
print(result)