const regex = /([{,])(\w+)(\s+)?:/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([{,])(\\w+)(\\s+)?:', 'gmi')
const str = `[{endTime:"2019-06-05T17:15:00.000+10:00",startTime:"2019-06-05T17:00:00.000+10:00"}]`;
const subst = `$1"$2":`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);