#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z0-9]+(?:[._-][a-z0-9]+)*$"
Local $sString = "this.is.Valid" & @CRLF & _
"also_a_valid_1" & @CRLF & _
"Me-too.im_an-ugly.but_vALid-5tring" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"this..should..not.be.valid...." & @CRLF & _
"THIS__.-also-should..fail-" & @CRLF & _
"why..IS_regex--so.confusing-for-n0obs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")