using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]+(?:[._-][a-z0-9]+)*$";
string input = @"this.is.Valid
also_a_valid_1
Me-too.im_an-ugly.but_vALid-5tring
this..should..not.be.valid....
THIS__.-also-should..fail-
why..IS_regex--so.confusing-for-n0obs";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}