const regex = /^[a-z0-9]+(?:[._-][a-z0-9]+)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]+(?:[._-][a-z0-9]+)*$', 'gmi')
const str = `this.is.Valid
also_a_valid_1
Me-too.im_an-ugly.but_vALid-5tring
this..should..not.be.valid....
THIS__.-also-should..fail-
why..IS_regex--so.confusing-for-n0obs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}