import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]+(?:[._-][a-z0-9]+)*$";
final String string = "this.is.Valid\n"
+ "also_a_valid_1\n"
+ "Me-too.im_an-ugly.but_vALid-5tring\n\n\n"
+ "this..should..not.be.valid....\n"
+ "THIS__.-also-should..fail-\n"
+ "why..IS_regex--so.confusing-for-n0obs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}