$re = '/^[a-z0-9]+(?:[._-][a-z0-9]+)*$/mi';
$str = 'this.is.Valid
also_a_valid_1
Me-too.im_an-ugly.but_vALid-5tring
this..should..not.be.valid....
THIS__.-also-should..fail-
why..IS_regex--so.confusing-for-n0obs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);