import re
regex = re.compile(r"^[a-z0-9]+(?:[._-][a-z0-9]+)*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("this.is.Valid\n"
"also_a_valid_1\n"
"Me-too.im_an-ugly.but_vALid-5tring\n\n\n"
"this..should..not.be.valid....\n"
"THIS__.-also-should..fail-\n"
"why..IS_regex--so.confusing-for-n0obs")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")