#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)_\D+"
Local $sString = "KM1208_sta1_cast3" & @CRLF & _
"KM1208_sta1_cast6a" & @CRLF & _
"KM1208_sta1_cast6b" & @CRLF & _
"KM1208_sta2_cast7" & @CRLF & _
"KM1208_sta2_cast6" & @CRLF & _
"HS1301_sta1_cast2" & @CRLF & _
"HS1301_sta2_cast5" & @CRLF & _
"HS1301_sta3_cast8" & @CRLF & _
"HS1301_sta3_cast9"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)